如何安装Android SDK以及如何设置你的开发环境

发布时间:2011年05月13日      浏览次数:876 次
安装 SDK
本页内容介绍如何安装Android SDK以及如何设置你的开发环境。如果你还没有下载SDK,你可以点下面的连接进行下载,然后阅读后续文档学习如何安装,配置,并使用该SDK来创建Android应用程序。

下载 SDK
http://code.google.com/android/download.html

升级?
如果你已经用更早的版本开发过程,可以跳过本页,并阅读升级 SDK文档.

系统和软件需求
用Android sdk的代码和工具开发Android应用程序,你需要适合的开发电脑以及开发环境,如下描述:

所需操作系统:

Windows XP 或 Vista
Mac OS X 10.4.8 或更高版本 (仅支持x86)
Linux ( Linux Ubuntu Dapper Drake 版本已测试)
所需开发环境:

Eclipse IDE
Eclipse 3.3 (Europa), 3.4 (Ganymede)
Eclipse JDT 插件 (大多数的 Eclipse IDE 包包含)
WST (可选,但Android编辑器的功能需要,它被包含在most Eclipse IDE packages 中)
JDK 5 或 JDK 6 (只有JRE是不够的)
Android Development Tools 插件 (可选 )
不兼容GNU Java编译器(gcj)
其他开发环境或 IDE
JDK 5 或 JDK 6 (仅有JRE不够)
Apache Ant 1.6.5 或更高版本( Linux 和 Mac环境下), 1.7 或更高版本( Windows环境下)
不兼容GNU Java编译器(gcj)
注: 如果你的电脑上已经安装了jdk,请确定它是上面所列的版本号。另外需要注意有些linux版本可能包含有jdk 1.4 或者 java 的gnu编译器,Adroid开发是不支持在这两种版本


安装 SDK
下载完SDK后,把.zip文件解压到你电脑上合适位置. 默认情况下, SDK文件被解压到 android_sdk_<platform>_<release>_<build>文件夹. 这个文件夹包含 tools/, samples/等.

请注意系统里SDK解压后的文件夹的名字和位置 — 当你安装Android插件和使用SDK工具时,你将需要引用这个文件夹。

你可以添加 SDK tools 的文件夹路径到你的环境变量中. 如上所述, tools/文件夹位于SDK文件夹中。

Linux环境下,修改~/.bash_profile或者 ~/.bashrc文件. 找到环境变量设置的地方,加入tools/的绝对路径。如果找不到该设置,你需要新添加一行:
export PATH=${PATH}:<your_sdk_dir>/tools
Mac环境下,在你的home文件夹里面查找.bash_profile,然后和linux一样处理。如果之前没有.bash_profile文件,你可以创建一个新的。
Windows环境下, 右击我的电脑, 并选择属性. 在标签页高级, 点击环境变量, 当对话框出现, 在系统变量栏目里双击路径 ( Path ) .并添加tools/ 文件夹的完整路径.
添加 tools 到你的环境变量里,这样你可以运行Android Debug Bridge (adb)和其他tools下命令,而不需要输入完整路径名。需要说明的是, 如果你升级你的SDK, 需要将你的相应环境变量更新到新的位置。

安装 Eclipse 插件 (ADT)
如果你要使用 Eclipse IDE作为开发Android应用的环境,你可以安装支持Android工程和工具的通用插件Android Development Tools (ADT). ADT插件包含强大的扩张,使得创建,运行和调试Android 更快速,更简单。

如果你不使用 Eclipse IDE,就不必下载和安装ADT插件

下载和安装ADT插件,请按照你们各自Eclipse版本步骤安装。

Eclipse 3.3 (Europa)
1、开始Eclipse,然后选择 Help > Software Updates > Find and Install....
2、对话框出现后,选择 Search for new features to install 点击 Next.
3、点击New Remote Site.
4、在对话框中,输入远程站点的名字(如Android Plugin),输入站点如下:
https://dl-ssl.google.com/android/eclipse/
点击OK.
5、你可以看到新的站点添加到搜索列表中(并检查),点击Finish.
6、在下面的搜索结果对话框,选择复选框 Android Plugin > Developer Tools. 它将会检查特性: "Android Developer Tools", 和 "Android Editors". Android 编辑器的特性是可选的,但我们推荐安装它,如果你选择安装,需要前面提到的WST插件。点击 Next.
7、阅读许可协议,然后选择接受许可协议,点击 Next.
8、点击 Finish.
9、ADT插件没有签名,你可以点击“Install All”来安装所有东西。
10、重启 Eclipse.

Eclipse 3.4 (Ganymede)

7、启动 Eclipse, 选择 Help > Software Updates....
2、在出现的对话框里,点击标签页 Available Software.
3、点击 Add Site...
4、输入下面的地址:
https://dl-ssl.google.com/android/eclipse/
点击 OK.
5、返回可用软件的视图,你会看到这个插件. 选择下一步到 Developer Tools 并点击 Install...
6、在接下来的安装窗口,选中"Android Developer Tools"和 "Android Editors"。Android编辑器特性是可选的,但是我们推荐安装它,如果你选择安装,需要前面提到的WST插件。点击 Finish.
7、重启 Eclipse。


重启之后, update your Eclipse preferences 指向SDK文件夹:

选择 Window > Preferences... 来打开属性面板。 (Mac OS X: Eclipse > Preferences)
从左边面板选择 Android。
在主界面上定位SDK 点击 Browse... 然后定位 SDK文件夹。
点击 Apply, 然后点击 OK。
ADT 安装疑难解答
I你如果按照以上步骤下载ADT插件有疑问,这里是一些建议:

在第四步,尝试改变远程更新地址URL为http,而非 https.
如果你在防火墙保护下(企业防火墙)请确定你的Eclipse的代理设置合适。在Eclipse 3.3/3.4,你可以从主Eclipse菜单中配置: Window (在 Mac, Eclipse) > Preferences > General > Network Connections
如果无法安装下载的ADT插件到Eclipse,按照如下的步骤来从你的电脑下载和安装插件:

下载ADT压缩文件 (不解压).
按照默认安装的第一部和第二步(如上).
在 Eclipse 3.3, 点击New Archive Site....
In Eclipse 3.4, click Add Site..., 然后点击Archive...
浏览和选择已经下载的压缩文件。
从第五步开始完成上面剩下的流程。
更新你的插件,你必须按照这些步骤代替默认的更行说明。

更新 ADT 插件
在某些情况下,你机器上的SDK可能和ADT插件是兼容的,你可以用以下步骤从Eclipse里更新ADT插件。

Eclipse 3.3 (Europa)

1、选择 Help > Software Updates > Find and Install....
2、选择Search for updates of the currently installed features 并点击 Finish.
3、如果 ADT可以更新,选择并安装更新。
或:
1、选择 Help > Software Updates > Manage Configuration.
2、展开导航树并选择 Android Development Tools <version>
3、Available Tasks 下选择 Scan for Updates。

Eclipse 3.4 (Ganymede)

1、选择 Help > Software Updates...
2、选择标签页 Installed Software。
3、点击 Update...
4、如果 ADT允许更新,选择它并点击 Finish.


安装注意事项
Ubuntu Linux 注意事项
如果你需要帮助安装和配置java在你的ubuntu机器上,下面资源可能对你有帮助:
https://help.ubuntu.com/community/Java
https://help.ubuntu.com/community/JavaInstallation
这里有java和Eclipsed的安装步骤,先安装Android SDK和ADT 插件.
如果你你开发机上使用64位版本,你需要用 apt-get安装 ia32-libs 包
apt-get install ia32-libs
下一步,安装 Java:
apt-get install sun-java6-bin
Ubuntu 包管理器现在没有提供Eclipse 3.3版本下载,因此我们推荐你从eclipse.org (http://www.eclipse.org/ downloads/)下载。 建议使用Java或RCP版本的Eclipse.
按照前面部分的提供步骤来安装SDK和ADT插件.
其他版本 Linux 注意事项
如果你在安装Eclipse的ADT插件遇到这个错误:
An error occurred during provisioning.
Cannot connect to keystore.
JKS
你的开发环境缺少适合的虚拟机,安装 Sun Java 6可以解决这个问题,然后你再重新安装ADT插件。
如果JDK已经安装到你的开发电脑上,请确定其版本在这页的顶部列表中已经列出,有些Linux包含jdk1.4或者java的gnu编译器,以上二者Android不支持。
免责声明:本站相关技术文章信息部分来自网络,目的主要是传播更多信息,如果您认为本站的某些信息侵犯了您的版权,请与我们联系,我们会即时妥善的处理,谢谢合作!